dev-templates/kotlin/flake.nix

30 lines
878 B
Nix

{
description = "A Nix-flake-based Kotlin development environment";
inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
outputs = { self, nixpkgs }:
let
javaVersion = 20;
overlays = [
(final: prev: rec {
jdk = prev."jdk${toString javaVersion}";
gradle = prev.gradle.override { java = jdk; };
kotlin = prev.kotlin.override { jre = jdk; };
})
];
supportedSystems = [ "x86_64-linux" "aarch64-linux" "x86_64-darwin" "aarch64-darwin" ];
forEachSupportedSystem = f: nixpkgs.lib.genAttrs supportedSystems (system: f {
pkgs = import nixpkgs { inherit system; };
});
in
{
devShells = forEachSupportedSystem ({ pkgs }: {
default = pkgs.mkShell {
packages = with pkgs; [ kotlin gradle gcc ncurses patchelf zlib ];
};
});
};
}