NixOS-Config/home-manager/shared/default.nix

30 lines
400 B
Nix

{
inputs,
outputs,
lib,
config,
pkgs,
...
}: {
imports = [
./shell/helix
./shell/zellij
./shell/zsh.nix
./shell/starship.nix
./shell/eza.nix
./shell/hyfetch.nix
];
home = {
username = "lillian";
homeDirectory = "/home/lillian";
};
home.packages = with pkgs; [
# System tools:
vscode-langservers-extracted
sops
zsh
bat
];
}